Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.
Comment: remove publisher from developer/library/lint package

...

If you wish to build with Sun Studio, you need specifically patched versions of both Studio 12 (used to compile) and 12.1 (used for lint) to get consistent results. If you do not have access to these versions, skip this section and use GCC.

illumos-gate has not yet been validated with newer versions of Oracle Solaris Studio (although there were reports of successful building with version 12.3), and using an unpatched older compiler produces noise and, we have reason to believe, slightly incorrect output. The does not build correctly with version of Studio newer than 12.0, and there have been reports that using them anyone produces a system containing grave, data-corrupting bugs.  The patched compilers used to be available from Sun Microsystems, but weren't redistributable. After a recent Oracle site reorganization, they are no longer available.

...