Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

...

You need to install several packages in order to build illumos.

  • On OpenIndiana Hipster, it's enough to install build-essential meta-package

...

Code Block
titleOpenIndiana Hipster mods
# Set version which is greater than current OpenIndiana Hipster build numbers, ONNV_BUILDNUM is ignored if PKGVERS_BRANCH is set:
export PKGVERS_BRANCH=2017.3.0.0 

# Set to current perl version
export PERL_VERSION="5.22"
export PERL_PKGVERS="-522"

# If you are building on the latest OpenIndiana Hipster (2017-03-07 and later)
export BLD_JAVA_8=

...

Cure: Builders must either set JAVA_ROOT to an installation location of JDK7, or must have /usr/java populated with JDK7 (or pointing to an installation location of JDK7). You can use whatever distribution of JDK7+ works for you best (packages or tarballs, OpenJDK or Sun/Oracle JDK).


If you are on the latest OI HipsterOpenIndiana, you want to install runtime/java/openjdk8 and developer/java/openjdk8 packages. Then in your env file, set:

...